Wednesday, October 21, 2015

EON ZFS Storage 151a9-071215 release!

New to EON, read here first! Upgrading, read here first!
For new setups:
If your EON Storage is internet connected. The EON ISO can be retrieved using wget.
After running setup(new setup) or (upgrade/backup). Re-check/edit your POOL=poolname in /mnt/eon0/.exec.
This is an option to edit "YOUR_POOLNAME" with a simple command if you wish to avoid "vi" (substitute your pool name where "YOUR_POOLNAME" appears). A backup file will be saved as .exec.bak
cd /mnt/eon0
sed -i.bak 's|=abyss|=YOUR_POOLNAME|g' .exec
An alternate upgrade option, using a spare USB key. Perform a new setup and then a forced zpool import to test. Perform the necessary tests and make sure all is ok before running:
zpool import -a -f /mnt/eon0/boot/x86.eon
After running the new install for a few days and triple checking everything is ok. Only zpool/zfs upgrade is left, to access the new features of zpool version 28 and zfs version 5. Note that once zpool/zfs upgrade is done, there is NO GOING BACK to the older version.
zpool upgrade poolname
zfs upgrade -r poolname
EON 64-bit x86 CIFS ISO image version 151a9-071215
  • eon-cifs-151a9-071215.iso ( no mirror )
  • MD5: 5c96f7f7aed83d0e0e88d55b4d46b925
  • Released: Wednesday 21-October-2015 (size: ~100MB)
EON 64-bit x86 CIFS KVM ISO image version 151a9-122315
  • eon-kvm-151a9-122315.iso ( no mirror )
  • MD5: 725d72a9b5b7d02801f2ef2e177907ac
  • Released: Saturday 26-December-2015 (size: ~109MB)
  • Note: KVM requires a Core i3 or higher Intel CPU
EON 64-bit x86 Samba ISO image version 151a9-071215 (NO HTTPD)
  • Status: Discontinued
EON 32-bit x86 CIFS ISO image version 151a9-122815 EON(commercial version eye candy) + awesome (window manager)


us said...

thx for the new release.

I went for a fresh setup.
I have to force the import of my zpools in .exec.
I have the restart the smb/server in .exec after the forced import.

I'm unable to install the binary kit.
docs under to old ?
(stuck at: wget -q -U mozilla -O /usr/bin/rail

zpool/zfs has not changed from 151a to 151a9, was already version 28/5.

Andre Lue said...

Don't update the (rail, setup, install, updimg or emp) for now. The version in the 071215 image are newer than the versions on the package downloads. I will update those shortly.

I will look into the binary kit download issue.

If you wish to avoid a forced import cp /etc/hostid (current image) to /etc/hostid (new image) and run updimg, then reboot. It should automount the pool if all went well.

Andre Lue said...

Hi us,

It seems dropbox limited downloads to https, no http. The quick fix is to edit /bin/rail.

search for the "pkg2.hash" change the URL from "http" to "https"

updimg will be required at some point to make it permanent past a reboot.

us said...

hi Andre,

both (old 1.0b=151a and new 151a9) /etc/hostid-files were with an empty/non valid ID



on my old 1.0b-system I had also to force the import, my pools were from 0.5xx times.

I found out the hostid of my pools were missing even the hostid-property was missing, also both missing in /etc/zfs/zpool.cache

checked with:
(not imported state)
zdb -l /dev/dsk/c3t0d0s0 | grep hostid

(after forced imported)
zdb | grep hostid

after a forced import and an export, I was always able to do an import without -f until the next reboot. but the pools still have no hostid inside the "label-structure".

I was able the recover the hostid from a "non-working-backup" (restoring the backup with usb-image-tool resulted in a non booting grub). but I scanned the backupfile with an hex-editor, found an old zpool.cache with 14 hostid's, converted the hex-value in the asci-format which was needed for /etc/hostid-file, run, reboot.

after one final forced import my pools have again a hostid and I'm able to do import without -f even after a reboot coz matching hostids.


I also got binkit and perl installed.
the links inside pkg2.hash needed also renaming from to

Andre Lue said...

If you boot the oem firmware and run hostid do you get a proper hostid? If not you may have hardware that I've seen this bug with. See release notes for more info.

If it shows a proper hostid re-run setup with the clean oem image, then updimg to lock it in. Reboot and note if the same hostid returns then do a force import. You should be all set.

Somerandom said...

Hi Andre,

Great to see the new release!

Any chance I could get a 32 bit download? Pretty please? :-)

us said...

hostid from the oem firmware gives me 00000000.

with an empty/non valid hostid the forced import of my pools did not change label-structure of my pools (maybe the first time: it cleared a valid hostid from the label-structure).
so for years a had to do a forced import every reboot. maybe in EOn 0.5xx hostid worked correct on my machine and my pools got the hostid written in the label-structure.

Andre Lue said...

@us, can you tell me what's spec of your hardware where oem /bin/hostid fails? To get a valid hostid, you could do is boot the oem image on another hardware and run hostid. Save and use the one from a working system.

@Somerandom, since it does take some time, can you give me a reason you're using a 32 bit image. Based on the reason/time, I'll consider it.

us said...

It's a mobile Core 2 Duo T5600 on 945GT Speedster-A4R from MSI's workstation/server department, later this board got re-released from MSI's desktop devision.

My pools were created with a prior EON-release and my pools had a hostid inside the label-structure, so I assume in a prior EON-release hostid gave a valid hostid.

After too forcing import of my zpools in newer EON-releases the hostid got cleared in the label-structure (even the fielddescriptor).

After getting feed up with forcing the imports after latest EON-release I started investigating ... I found my old hostid in the mentioned backup ... yes I could had use any fantasy-hostid or one from an another system.

us said...

this piece of hardware is 9+ years old ... with an Intel SASUC8I flashed to LSI SAS3081E... with 12x SATA drives

Erwin said...

Hi Andre,

I arrive a bit late at the show.. I have't been running eon lately.
Could you explain a bit more about KVM capabilities in EON? Or point me to the relevant information.
I did a search on Google groups but found little to no information.

I read that you suggest minimum i3 cpu, I also guess the more memory the better.
I'm sorry, but I have no experience with KVM. Mostly use vmware-fusion on my mac.
But it would be interesting to be able to run 2 or 3 lightweight virtual machines on top of an EON nas.

Thanks once more for keeping up the good work!


Erwin said...


Forgot one more thing:
I read on the blog: "commercial version eye candy"
Is a commercial version up already? Can you point me to more information please? Price etc?

Thanks a lot!


us said...

hi Andre,

I setup another machine as EON storage - fresh with 151a9.

1.5 years ago was already outdated and from 2016-10 there is also the blogentry.

what is the correct way to install the binkit on a fresh 151a9 setup ?